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Detailed leveling parameters

Introduction

How many of us view the many levelling parameters within Microsoft Project as
a bewildering array of options? How many of us have clicked the ‘Level Now’
button and wished we hadn’t?

As the levelling process can reschedule both tasks and assignments, it is
important to understand how levelling works and what it does to your
project’s schedule. Once you know the benefits and the possible pitfalls
associated with levelling, you will be able to decide when and how to use this
powerful tool, confident that it is trying to optimise your project and not being
detrimental to it. These tips and tricks explain the options available and the
impact that they can have.

Background

When resource leveling is carried out, the method of leveling is determined by
a number of leveling parameters. Some of these parameters are general in
nature, some are more detailed. The effects of making detailed parameter
changes can still have wide-ranging effects upon the project's schedule.
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Detailed leveling parameters

Allowing assignment adjustment

When tasks have several assignments against them, leveling becomes more
involved. Take the situation below:

- Project P —
Milestone 1 3
Task ¥
Task v
Task Z i
Milestone 2 +*
& | Resource & BOhre | work 16h: 16h: 16h: 16h: 16h
Task X A0 hrs | ywork ghi &hi ahi Shi 8h
Task Z H2hrs ok Bhi 8hi 8hi Bhi Bh
= Rezource B B0hrs ek Bhi Bhi Bhi Bhi Bh 8hi Bhi Bhi Bhi Bh
Task ¥ 20 hrs | wiork Ghi 8hi 8hi Shi 8h
Task 2 40 hrs ok 8hi Bhi 8hi Bhi Bh

e There is a resource conflict for Resource A in week 1 (parallel
assignments on Task X and Task Z).

e Resource B has no conflicts.

e It will not be easy to apply a leveling delay to Task Z without creating a
conflict for Resource B on Task Y and Task Z.

If the tasks require the resources to be working at the same time, resource
leveling would resolve the conflict thus:

a. From the Tools menu, choose Level Resources.

b. Set the 'Resolving overallocations' options to be as below, then
Level Mow

Resalving overallocations

Leveling order: | Standard j

™ Level onlyiithin available slack

I EL_evﬂng can adjust individual assignments on aEasLi_

[V Leveling can create splits in remaining work

c. Changing the project's schedule to be:

=l Project U y
Milestone 1 j
Task ¥ Resource A
Task ¥ R ce B
Task I Resource A,Resource B
Mile=tone 2 &
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Detailed leveling parameters

=l Resource A Wiark 8highighiBhish 5hiBhiBhiBhish
Task X Wiark ShiBhiBh: Bhigh
Task Z Witk ShidhighiGhigh

=l Resource B Witk 5highiBhiBhish Shighishishish
Task ¥ Witk ShiBhiBhishish
Task Z wiork Shighighighigh

o Task Z has been rescheduled so that BOTH Resource A AND
Resource B are able to work upon it.

o As aresult, Task Y must be rescheduled so that its assignment for
Resource B is not in conflict with the rescheduled Task Z.

If a task can start as soon as either of the resources assigned to it can start,
resource leveling would resolve the conflict thus:

a. From the Tools menu, choose Level Resources.

b. Set the 'Resolving overallocations' options to be as below, then
Lewvel Maw

Resolving overallocations

Leveling order: | Standard j

[~ Lewvel only within available slack

C:F_friffveling can adjust individual assignments an a t__aski

[V Leveling can create splits in remaining work.

¢. Changing the project's schedule to be:

- Project P———

hiile=tone 1 0

Task ¥ Resource A&

Task ¥ Resource B

Task I Resource A,Resource B

hiilestone 2 *

=l Resource A Wiork BhighiBhishish Bhith Bhith Bh!
Task X Wiork Bhighighishish
Task 2 Wiork OhiOhi0hiOhiOh BhighiBhiohish

=] Resource B Work 8highighishish ghighishishish
Task ¥ Wik Bhithighishigh
Task 2 Wiork Shishichich ah

o Resource B can start its work on task Z immediately and be complete
by day 5 (before Resource B must start work on Task Y).

o Resource A's work on Task Z can not commence until work on Task
X'is over and as a result Task Z can not finish until day 10.
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Detailed leveling parameters

e Allowing assignment adjustment can result in tighter (and possibly more efficient)

schedules and earlier project finish dates.
As assignment adjustment can affect task duration values, the 'Level Assignments'

field will be set to No for fixed duration tasks.
Assignment adjustment can be set on a task-by-task basis. Simply add a column to a

table including the 'Level Assignments' field.

Hints
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Detailed leveling parameters

Allowing task splitting

Often, when parallel assignments exist, one task has a higher priority than
another:

Tazk &
Tazk B
Tazk <

Lowver priarity task

Resource A

&> |E Resource A Wiork 8hi 8hi 8hi &hi ah 16hi16h 16h 16h 16h
Task B Winrk 8hi 8hi 8hi Bhi 8h
Lawer priarity task | wiork Bh! 8hi 8hi Bhi Bh ghi Ghi Bhi Bhi Bh

o There is a resource conflict for Resource A in week 2 (parallel
assignments on Task B and the Lower priority task).

If the lower priority task can not be split, resource leveling would resolve the
conflict thus:

a. From the Tools menu, choose Level Resources.

b. Set the 'Resolving overallocations' options to be as below, then
Level Mow

Resolving overallocations

Leveling order: BPriority, Standard j}

™ Lewel anly within available slack

¥ Levelin adjust individual assignments on a task,
@ﬁiﬁcreate =plits in pemaining works

c. Changing the project's schedule to be:

Taszk &
Task B
Tazk C

Lowwver priarity task

Resource A

e The lower priority task has a leveling delay until the beginning of the
third week.

e The lower priority task must wait until there is a period of availability
for Resource A (once Task B has been accomplished).

e A 2-week delay has been introduced into the project and the lower
priority task has become critical.
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Detailed leveling parameters

If it is possible for leveling to split tasks, the conflict could be removed thus:
a. From the Tools menu, choose Level Resources.

b. Set the 'Resolving overallocations' options to be as below, then
Level Mow

Resolving overallocations

Leveling order: |Pri0rity, Standard jJ

™ Lewel anly within available slack
[¥ Leveling can adiust individual assignments an & task
¥ [ eveling can create spiits in remaining work:

c. Changing the project's schedule to be:

Tazk &
Tazk B
Tazk C
Lowwver priority task Resource &
Task: Lower priority task
Skark: Feb 6 '04
Finish: Feb 16 '04
- Resource A Wik Shighighighigh Shighighighish Shighit
Task B Witk Bhihishishish
1@3} Lower priotity sk | vork Bh:8hishishish L H Bhighis
]fﬁl This assignment work has been
| edited,

o The lower priority task can start straight away (as Resource A has no
other assignments in week 1).

o Work on the Lower priority task temporarily suspends during week
2, whilst Resource A works on the higher-priority Task B.

o Work resumes on the Lower priority task once Task B is finished.
o The delay to the project is only one week.

e Allowing task splitting can result in tighter (and possibly more efficient) schedules and
earlier project finish dates.
[} e Task splitting creates contoured assignments.
£ The ability to split tasks can be set on a task-by-task basis. Simply add a column to a
T table including the 'Leveling Can Split' field. Note that although splitting is permissible
for fixed duration tasks, this should really be set to 'No' as a fixed duration task
shouldn't have its duration increased as a result of leveling.
" (77 Project Learning International Limited
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Detailed leveling parameters

Choosing who to level

When Microsoft Project performs resource leveling, it is possible to select just
certain resources to be leveled. This can leave other resources unleveled, even
if those resources still have conflicts against them. The ability to do this
depends upon the type of view that is currently active:

e In a task-based view (Gantt chart, Task Usage for example) ALL
resources will be leveled.

e In aresource-based view (Resource Sheet, Resource Usage for example)
it is possible to level only selected resources.

Consider the Gantt chart below. There appears to be two separate resource
conflicts:

=| Subproject A L w
Tazk &1
Task &2
Task &3
Taszk Ad
- Subproject B L
Task B
Taszk B2
Tazk B3
hlilestone Bd »

Resource X

Resource ¥

Resource X

Resource ¥

o Resource X in week 1.
o ResourceY in week 3.

To level just resource X and not resource Y:

a. From the View menu, select Resource Usage (as this will also show the
change to the assignments).

b. Select the resource to level:

YWork 16R116h 16k 16h HER
Task A1 | gk Bhi Bhi Bhi Bhi Bh
Task BT | wiork Bhi 8hi 8hi 8h! &h
=] Resource ¥ Wark Bhi Bhi Bh: Bhi Bh 16h16h: 16hi16R: 16h
Task AZ | | wiork 8hi 8hi 8hi &hi 8h &hi 8hi 8hi &hi 8h
Task B3| | ok ghi ahi 8hi gkl &k

c. From the Tools menu, choose Level Resources, then m
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Detailed leveling parameters

d. Choose to level just the selected resource(s), confirmed with OK.

 Entire poal oK |
ﬂcted rESOUFCES

Cancel

e. Displayed in the Resource Usage and Leveling Gantt Views as:

e K Wiark Bhi Bhi Bhi Bh! 8h Bhi Bhi Bhi @hi sh
Task A |k Bhi &hi 8h 8kl &h
Task B1 | | yyiork Bhi Bhi Bhi Bhi 8h
-l Resource ¥ Wiark Shi Bhi Bhi Bhi gh 1Bhi1Eh i 16h 16hi1Eh
Task AZ | | wiork 8hi 8hi 8hi &hi 8h &hi 8hi 8hi &hi &h
Task B3 | work Ghi 8hi 8hi Bhi &h
-| Subproject & L y
Tazk &1 E Resource X
Taszk &2 Resource Y
Task &3
Task &4
= Subproject B L . g
Task B1
Task B2
Tazk B3 Resource Y
Milestone B4 *»

e Task B1 has the leveling delay applied to it (according to the current
leveling order).

e Tasks A2 and B3 have no leveling applied as Resource Y was not
selected to be leveled.

e  Use resource-selective leveling for what-if analysis regarding the demand/availability
2 of key people.
T e By default, all resources can qualify for leveling. This can be varied on a resource-by-
resource basis. Simply add a column to a table including the 'Can Level' field.
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Detailed leveling parameters

Leveling beyond slack

A further leveling option is to investigate the effect that the available slack
within the project has on the resource leveling process:
e Can leveling extend tasks within the project beyond their slack values?
o Can tasks be extended / delayed beyond their latest finish dates?
o Can the project finish date be delayed?
e Must leveling be conducted within the slack that is available?
o Tasks must not be extended / delayed beyond their latest finishes.
o The project finish date can not be delayed.
Consider the Gantt chart below:

- Subproject A L v
Task &1
Tazk A2
Tazk A3
Task &4
-| Subproject B L
Taszk B1
Task B2
Task B3
Milestone B4 +*

Resource X

Resource X

o There appears to be enough free slack on Task B1 to allow it to be
levelled without it extending beyond its latest finish date.

o Both Task A2 and Task B3 are critical tasks. Any delay to them
would extend the end date of the project.
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Detailed leveling parameters

To allow the project to be leveled beyond slack (float):

a. From the Tools menu, choose Level Resources.

b. Set the 'Resolving overallocations' options to be as below, then

Level Mow

Resolving overallocations

Leveling order: Standard j
—
Lewel anly within available slack:
¥ Leveling can adijust individual assignments on a bask

¥ Lewveling can create splits in remaining work

Changing the project's schedule to be:

-| Subproject A L v
Task Al g
Task A2
Task &3
Task &4
=l Subproject B L y
Taszk B z
Taszk B2
Taszk B3
Milestone B4 fe &

. Resource ¥

o Task B1 has a leveling delay applied to it that is <= it's available
slack. As such it has not delayed the project (although it has
become a critical task).

o The leveling delay against Task B3 has extended its scheduled finish
beyond its original late finish date. It has therefore delayed
Milestone B4 and hence delayed the project finish date.

e [f there is enough available slack, Microsoft Project will attempt to delay the project
without extending the project finish date if it possibly can.

e If tasks or milestones have inflexible constraints against them, leveling beyond slack
can create schedule conflicts.

Hints
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Detailed leveling parameters

Leveling within slack

To see the effect of leveling the project within slack:
a. From the Tools menu, choose Level Resources.

b. Set the 'Resolving overallocations' options to be as below, then
Level Mow

Resolving overallocations

Leveling order: Standard j
-
v Level only within available sIack_;D

W Leveling can adjust individual assignments on a bask

¥ Leveling can create splits in remaining work

c. As the overallocation can not be resolved within the available slack a
is given. To find out what amount of leveling is

warning message

possible, click

Microsoft Office Project E
Project cannat resolve the overallocation of "Resource ¥ on Feb 16 '04.

': + To continue leveling other overallocated resources, click Skip.

+ To continue leveling and skip overallocations that cannot be resolved, dlick Skip Al

+ To stop leveling, chick Stop. To remove the effects of leveling, in the Resource Leveling dialog box, dick Clear Leveling.

| skp | [ skpall | [ stop |
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Detailed leveling parameters

d. Changing the project's schedule to be:

-] Subproject & L v
Task &1 Resource X
Task &2
Task A3 A
Task &4 +
=] Subproject B L v
Tazk B1
Taszk B2
Tazk B3
Milestone B4 +»

g Wiork Bhi 8hi 8hi Bhi Bh Bhi 8hi 8hi Bhi 8h
Task AT | work Bhi 8hi gkhi Bhi gh
Task B gk Bhi 8hi 8hi Bhi &h
-l Resource ¥ Wiork 8hi 8hi Ehi Bhi 8h 16k 18R 1Bhi1Bh 16k
Task A2 || wjork 8h! 8hi 8hi Bhi 8h 8hi 8hi 8hi Bh! Bh
Task B3| | work 8hi Bhi Bhi Bhi 8k

Task B1 can be leveled within its available slack.

Task B3 hasn't been leveled as its late finish date can not be extended.
As a result, a conflict still exists for Resource Y.

e |f the leveling process is stopped ( ﬂ), leveling delays may still exist. To

% remove leveling delays, use the 222" Leveling... b o within a task-based view.

T e Changes to the 'Resolving overallocations' options are not saved within a local project
document, they are saved within the PC's registry. As such, the settings will apply to
all projects.
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